Thursday, January 29, 2009

Nortel Graffiti

My current contract has me working in the Skyline Campus in Ottawa. This 8 building complex was purchased by PWGSC back in 2003 when it was still occupied by Nortel. It is now occupied by Agriculture and Agri-Food Canada (AAFC) and Canadian Food Inspection Agency (CFIA).

This is the end of my first week at this new location, and more AAFC people are moving into this campus all the time. It seems that not everything was cleaned up from when Nortel was here. On the 2'nd floor mens room there is graffiti which is clearly left over from Nortel.

Some things seen on the walls of the stalls:

"How the " (not to be blogged) "does Nortel expect me to feed my kids"
" --->"

An irony for those who know some of the mistakes that Nortel made that meant that they are in the hard times they are now: all the desks and conference rooms (and so-on) in this complex have Cisco IP phones.

Wednesday, January 14, 2009

Letter to CBC and Clive Doucet about OCTranspo drivers strike

The following was sent yesterday morning to CBC Morning and to my councillor Clive Doucet. I think we need to fire any councillors that still support Mr. O'Brien in this issue.

I was appalled to hear on the radio this morning that Mr. O'Brien has injected himself as the sole representative of city council on this issue. I could say like some callers that I am "done" with Mr. O'Brien, but I was never with him in the first place. The only reason he is mayor is because we still use the antiquated First Past the Post electoral system. He was not the first choice of the majority of Ottawa voters, and if we used a modern ranked ballot voting system we would quickly have realized he wasn't their second or third choice either.

I believe it is overdue for city council to put in a better representative, or speak individually as representatives of their constituents. We don't elect the Union, and they are only intended to represent the drivers. Councillors are our only representatives in this important issue, and should be representing both current residents and future residents (IE: environmental deficits increased by this strike).

Monday, January 12, 2009

Linux video issues: boxing day punishment

I seem to have run into a number of problems with my video. I figured someone reading this might be able to offer some help, and getting some frustration off my mind might make me more calm.

I broke a personal rule this year: I participated in boxing day shopping. The Samsung SyncMaster T220 LCD monitor was on sale for $200. Since I wanted to stop using my old tube monitors to save electricity, I figured this would be a good time to do this and I bought two (one for my desktop, one for my wife Rina).

Took them home, plugged one into Rina's computer and it just worked right away. We set the resolution to a lower-than-maximum which was more to Rina's liking (1024x768). This computer is using the S3 Savage video built onto the motherboard (Chip: id 8d04, "ProSavage DDR-K"). It runs Ubuntu with xorg autodetecting everything based on a bare-minimum xorg.conf.

I plugged the other one into my computer and the screen simply displayed “Not optimum mode. Recommended mode: 1680x1050 60Hz”. Using system-config-display running from the console it could detect my card (Matrox G450 - Chipset: "mgag400", 16M Video RAM) and the monitor, but would never give a display mode that would work with the monitor.

I figured I would buy a new video card that would not only drive the monitor, but hopefully be accelerated so I could get those cool windowing effects/etc. I ordered an ASUS (Well, ATI) AH3450 card which was mentioned as supported by the radeon driver (It's listed in the "radon" man page).

This turned out to not work out well. While the card worked, it didn't seem to work for accelerated graphics at all. In fact, video seemed much slower than with the G450 card even when set to the same screen resolution.

I decided to experiment with the proprietary driver, just to see how this would work. The fglrx driver is bundled by rpmfusion, which I already use for a few video codecs/etc. This turned out as I expected given how well I find proprietary software to work: the driver was unstable and I didn't know when booting the system whether it was going to freeze up or not. I also saw a lot of odd flickering artifacts on the screen (Note: I did test this monitor with Rina's computer to see if the monitor was broken, and it is fine), which made it realistically unusable. The card also has audio for the SDMI interface and this seemed to kill my existing SB Live audio (IE: new audio device showed up, but my SB Live was gone. USB headset still worked).

I made an additional mistake: I figured that maybe the problem was outdated software, so I upgraded my Fedora Core 9 computer to Fedora Core 10. After I upgraded all the things that were still out-of-date after that badly done upgrade, I noticed no improvement with the radeon card.

I put the G450 back in the machine. Rather than restoring me to the previous working state, now my X video extensions are broken. I can run vlc and mplayer with slow video using the 'x11' video output driver (IE: `mplayer -vo x11 *.mp4` ), but 'xv' (IE: `mplayer -vo xv *.mp4` ) just shows me a blue window where my video would normally have been.

I seem to now have brought my computer to a state where video is broken with my G450 and tube monitor, as well as the Radeon and LCD monitor.

Any suggestions to try next would be appreciated.